Background playback not working [iPad 3, iOS 8.4.1]



  • Hi, i recently updated and upgraded. On my iPad 3, after being enabled, the background playback does not work. And even worse, when I switch from the app to another one, the interface 'reloads' and I need to go and manually restart the playing. It's very, very annoying.

    iPad 3
    iOS 8.4.1

    0

  • COMMUNITY REP

    @thegeeklady
    Settings -> Playback -> Background Playback is on??

    My device for Bug-Report:
    iPad Air 2 - iOS 9.2.1

    0


  • Yes, of course it is. I even tried changing some settings for hardware/settings decoding, since this seems to be a ram issue.

    iPad 3
    iOS 8.4.1

    0

  • COMMUNITY REP

    @thegeeklady
    Audio file? Come always this problem?

    My device for Bug-Report:
    iPad Air 2 - iOS 9.2.1

    0


  • They seems to work fine. That's why I'm thinking of a memory issue. I'll posti a video showing the issue in a few minutes.

    iPad 3
    iOS 8.4.1

    0


  • Here it is.

    iPad 3
    iOS 8.4.1

    1

  • COMMUNITY REP

    @thegeeklady
    All video files with this problem?

    My device for Bug-Report:
    iPad Air 2 - iOS 9.2.1

    0


  • Yes. I've tried avi, mkv and mp4.

    iPad 3
    iOS 8.4.1

    0

  • COMMUNITY REP

    @thegeeklady
    H.264 Codec? nPlayer 2.6.5 no problem?

    My device for Bug-Report:
    iPad Air 2 - iOS 9.2.1

    0


  • This is probably an issue on older devices. My iPhone 5s does this fine.

    iPad 3
    iOS 8.4.1

    0


  • @Fixed said:

    @thegeeklady
    H.264 Codec? nPlayer 2.6.5 no problem?

    Mmmm how do I check the codec? Should open the files in vlc?
    nPlayer 2.6.5 worked perfectly. I'm thinking of a rollback XD

    iPad 3
    iOS 8.4.1

    0

  • COMMUNITY REP

    My device for Bug-Report:
    iPad Air 2 - iOS 9.2.1

    0


  • AVI
    MKV
    Before wasting my money on that app, are these screens useful?
    They are from two files I played showing the issues.
    BTW, in rare cases, while testing, these same files worked fine the background playback. But it was really rare.

    iPad 3
    iOS 8.4.1

    0

  • COMMUNITY REP

    @thegeeklady
    Thank for your test :)
    All good, is only normal bug.

    My device for Bug-Report:
    iPad Air 2 - iOS 9.2.1

    0


  • @Fixed said:

    @thegeeklady
    Thank for your test :)
    All good, is only normal bug.

    You're welcome. Feel free to ask anything that might be useful to you.
    This is honestly good news to me, since I was afraid I had to give up this feature forever due to the oldness of my device XD
    Just one question: since I strongly use and love this app, do you suggest to rollback or just wait for a fix?

    iPad 3
    iOS 8.4.1

    0

  • COMMUNITY REP

    @thegeeklady
    I think you need this function. Install nPlayer 2.6.5 ^^

    My device for Bug-Report:
    iPad Air 2 - iOS 9.2.1

    0


  • @Fixed said:

    @thegeeklady
    I think you need this function. Install nPlayer 2.6.5 ^^

    Ok, but you have to know I'll crave for the next update XD
    I truly loved all the new features XD
    Again, if anything more is needed feel free to contact me.
    Thank you and have a nice day!

    iPad 3
    iOS 8.4.1

    1


  • @thegeeklady said:

    Here it is.

    I think, it's the same defect like discribed here: http://forum.nplayer.tv/topic/27/player-losses-position-of-played-video
    I have the same bahavior.

    iOS 8.4.1 (12H321)
    iPhone 5 64GB
    iPhone model: MD663RU/A

    0


  • Sorry, I read the title of your topic and didn't relay to the background playback feature, I thought it was something else. I'm not alone, yeah XD
    Admins, feel free to merge/delete the topic if it helps you to keep the forum in order :)

    iPad 3
    iOS 8.4.1

    1


  • First, sorry for late reply. This bug was caused by memory issue. We’ve fixed it. It’ll be applied to next version. Thank you for your concern about nPlayer.



  • I read that this was fixed and that the new version has been submitted to Apple, thank u! I'll update the post as soon as I check that the issue is solved :)

    iPad 3
    iOS 8.4.1

    0

Log in to reply