Subtitles bug in nPlayer - still not fixed after years



  • There’s a bug in nPlayer Plus, last version for the last iOS 11.

    The subtitle line ends but it does not fade after icontinues to be displayed after several seconds, at least until a new line from the subtitle has to be showed. In this case it’s a mkv with a SRT in it.

    Here’s proof
    https://m.imgur.com/a/UaFbx



  • When will this bug be fixed? I still saw in the iPAD Pro 10.5 (256 GB , wifi+cel, using iOS 10.3.2). Not sure if the last version released today has it, however it's a quite old issue that hasn't been addressed.



  • I believe the bug is still there. I spotted in the IPAD PRO 10.5, using iOS 12.1.1, so the last iOS.

    Is someone reading these threads?


  • administrators

    We have difficulty to figure out what the problem is with the information you gave us. Does it occur in all files?

    Please describe more detail about where you played(locally or network server type) and the steps to reproduce it. And your video and audio sample file would help us. If you can, in order to test in the most similar conditions to those where you did, please upload your sample file to ftp://test.newin.co.kr or give us your file link to support@nplayer.tv. When we get the sample, we will check the file and try to find out what the problem is.



  • Ok, since you asked to see this bug I'll show you. Since iOS 11 users are able to record the iPAD screen, so I was able for the first time to record the bug while it happened.

    This is a video from the bug:

    https://www.youtube.com/watch?v=ev84OEEswa4

    As you can see the subtitles are saying:

    • No way. No, sirree.
    • You don't have to.

    After several seconds these two lines fade from the screen. But only at 19 seconds when she says "Hey". Otherwise if the video lasted 10 minutes they would still be displayed after 10 minutes.

    Now look what happens when I try to play the same part again:

    https://www.youtube.com/watch?v=CBo5dIvUPR4

    These two subtitles fade imediatelly! After 1-2 seconds.

    What does that mean?

    • While I was playing for the first time nPlayer Plus showed the bug.

    The next time I tried to show the same bug it didn't happen.

    That's why it's so hard to prove this is a bug. But it is, indeed. And like I explained to you this is happening at least since 2017, during all these nPlayer versions and in ALL iOS releases.

    Considering what I just said it would be pointless to send you any file, because I saw this bug happening MANY TIMES, with different releases. The only thing they ALL had in common was the fact they were using SRT subtitles, added to a Matroska file.

    If still you want to look into this file download this link here:

    -------- THE LINK WAS SENT BY EMAIL - PLEASE CHECK YOU "SUPPORT" EMAIL ACCOUNT

    I won't send you an excerpt because it will be claimed I am altering the original file/contents. So this is the exact file I am playing here. If you want to edit this link later (after you get it), then do it.

    I hope now this can be solved, whatever the problem is.

    A possible scenario was the fact this moment (from the subtitle) was not edited correctly. I extracted the SRT using MKVExtractGUI. This is what I found:

    799
    01:12:10,390 --> 01:12:14,100
    This is where I draw the line.
    I'm not going up in one of those things.

    800
    01:12:14,100 --> 01:12:17,640

    • No way. No, sirree.
    • You don't have to.

    801
    01:12:38,370 --> 01:12:40,390
    Hey!

    Do you see any issue at #800? I don't. It lasts only 4 seconds. However in the 1st Youtube video (showing the bug) nPlayer disregard that.

    Why? I was never able to find out.

    EDIT: I am now thinking this can possibly explain the error: the "line" #800 starts at the same moment #799 ends: 01:12:14,100.

    This is very likely to be the reason why this is happening. Still doesn't explain why it happens once and in the next times I try to see the bug is not repeated. And this shouldn't matter, anyway.

    Also: this NEVER happens with another player.


 

Looks like your connection to nPlayer Forums was lost, please wait while we try to reconnect.