SRT subtitles issue



  • Hello,
    Is there a possibilty that nPlayer recognizes subtitles situated in the same folder than the movie, files named as follows:

    name_of_movie.mkv
    name_of_movie.fr.srt

    For now, it does not work.

    By the way, I'm using Plex, and it is the way I use to get subs working.
    All my subs are named and located that way.

    Thank you.



  • @chrisl31
    To be more precise :
    I get access to my movies through Plex UPnP/DLNA server.
    When playing a movie on nPlayer/iPad, if I want to "add subtitles", as described in nplayer help, the opening window shows only "Local" and "opensubtitles.org" tabs options.
    I do not get the "network" tab, as shown in the help screen captures...
    So I cannot select my subtitle ...


  • administrators

    When we tested the file name, it recognizes and plays the subtitles. Please check it and give us more detail about where you played(locally or network server) and the steps to reproduce it.

    Since UPnP/DLNA server is for a media server, there is no standardized method of supporting subtitles and it might not load subtitle or text file format except for a media format like a video and audio. So network tab on adding subtitles is not supported on UPnP/DLNA at this time. We recommend you to use FTP, WebDAV or SMB for all kinds of subtitle support. Please take this into consideration. Thank you.



  • @support Thank you for your answer.
    I play my files from a network server : Plex Media Server which has the possibilty to activate itself as a DLNA server.
    nPlayer recognizes audio and video files from this DLNA server, and only embedded subtitles.
    My movies have external subtitles named and located as explained in my first post of this thread.
    And these are not read by nPlayer in my configuration.



  • @chrisl31 Hello, tell me, when downloading / buying a paid application, will those my files that were uploaded to the free version of the player disappear?



  • This post is deleted!


  • This post is deleted!


  • Sorry for that.
    I did not notice that it was very easy to set-up an SMB server in OSX :
    Sharing preferences (choose Apple menu > System Preferences, then click Sharing)
    File Sharing checkbox, then click Options.
    Select “Share files and folders using SMB.
    So now, with this SMB server, subtitles work as needed.
    Thanks.



  • Both file name should be same one is mkv and srt



  • @rakesh-bhargava
    Yes, the same name, and also with language info in the name (in the case of SMB server) as I said:
    name_of_movie.mkv
    name_of_movie.fr.srt
    name_of_movie.eng.srt


 

Looks like your connection to nPlayer Forums was lost, please wait while we try to reconnect.